www.SAMURAJ-cz.com 

15.12.2017 Radana a Radan Translate to English by Google     VÍTEJTE V MÉM SVĚTĚ

Články

Cisco Routing 1 - obecné vlastnosti směrovacích protokolů

Pátek, 20.03.2009 14:43 | Samuraj - Petr Bouška |
Tento seriál se věnuje routingu, tedy směrování v počítačových sítích. Jednotlivé popisy jsou obecně platné, ale zde jsou uváděny se zaměřením na produkty firmy Cisco a s popisem konfigurace v Cisco IOSu. Tento první díl probírá základní rozdělení routovacích protokolů a popis kategorií. Popisuje základní termíny a ukazuje obecné konfigurační příkazy IOSu. Dále se věnuje Policy Based Routingu, sumarizaci adres, filtrování a redistribuci cest.

Celý tento seriál o routingu vznikl, když jsem se připravoval na Cisco test 642-901 BSCI, jako moje poznámky. Následně jsem provedl pouze jednoduchou úpravu a text publikoval. Pokud myslíte, že něco podstatného chybí, něco není správně popsáno nebo není úplně jasné, tak uvítám vaše informace v komentářích.

Základy routování jsou popsány v článku TCP/IP - Routing - směrování.

Dělení routovacích protokolů

Do routovací tabulky se vytváří několik typů záznamů cest (routes), záleží na tom, jakým způsobem vznikly. Pakety jsou podle toho směrovány jedním ze základních způsobů routování:

  • statické routování - ručně zadané cesty (záznamy v routovací tabulce), bezpečné a dobré, ale nereflektuje změny v topologii sítě
  • dynamické routování - síť se automaticky přizpůsobuje změnám v topologii a dopravě, automaticky se vypočítávají cesty pomocí routovacího protokolu
  • defaultní routování - pokud neexistuje jiná cesta, tak se použije defaultní

Dynamické routovací protokoly jsou dvou základních typů:

  • Distance-Vector Routing Protocol
  • Link-State Routing Protocol

Pozn.: Také je zde Path-Vector Routing Protocol, který patří pod Distance-Vector Routing Protocol.

Dále dělíme dynamické protokoly podle toho, zda jsou určeny pro nasazení uvnitř lokální sítě (přesněji řečeno uvnitř autonomního systému (AS), který může obsahovat několik LAN) nebo fungují napříč sítěmi (spojují AS dohromady).

  • Interior Gateway Protocol - IGP - routuje uvnitř Autonomous System (AS)
  • Exterior Gateway Protocol  - EGP - routuje mezi AS
Dělení dynamických routovacích protokolů

Distance-Vector Routing Protocol

  • RIP, RIP2, IGRP, EIGRP, BGP
  • routery udržují routovací tabulku s informací o (vektoru) vzdálenosti do dané sítě
  • periodicky routovací tabulku zasílají sousedům, ti si upraví svoji tabulku a tu opět odešlou dál
  • pro výpočet nejlepší cesty se používá jedna (počet hopů u RIP) nebo více (propustnost linky a zpoždění u IGRP) metrik
  • upraveným typem distance-vector protokolu je path-vector protocol.
  • jednoduché DVRP (RIP, IGRP) nevytváří vztahy se sousedy
  • problémem jsou routovací smyčky (routing loops) - řeší se pomocí definice maximální vzdálenosti (TTL), Split Horizon (neposílá routu na rozhranní přes které přišla), Route Poisoning, hold-down timer (čekací interval, než je síť stabilní, prodlužuje konvergenci)

Link-State Routing Protocol

  • OSPF, IS-IS
  • routery udržují komplexní databázi síťové topologie (vytvořenou pomocí LSA)
  • vyměňují si Link State Advertisements - LSA, LSA jsou vyvolány nějakou událostí v síti, také Link State Packet - LSP nebo Link State PDU
  • do svého okolí také odesílá Hello pakety, kde zasílá informace o sobě
  • rychle reaguje na změny topologie, ale spotřebovává více pásma (hlavně na počátku zasílá množství LSP) a zdrojů na routeru
  • metrika je komplexní, nejlepší cesta se počítá pomocí Dijkstrova algoritmu shortest path first - SPF
  • pro zlepšení vlastností se rozděluje na menší oblasti, hraniční routery posílají sumární cesty, využívá multicast, číslování LSA

Obecné termíny

Autonomous System - AS

  • je skupina IP sítí a routerů, které jsou pod stejnou technickou administrací
  • čísla 1 až 65535
  • privátní rozsah 65512 - 65535
  • AS používá EGP pro komunikaci s jinou AS
  • uvnitř AS se routy naučené z BGP mohou redistribuovat do IGP

Administrative Distance - AD

  • určuje důvěryhodnost protokolu - definuje spolehlivost protokolu a prioritizuje lepší nižším číslem
  • je vlastnost používaná na routrech k určení nejlepší cesty mezi více routovacími protokoly
  • Jinak řečeno na routeru může běžet více routovacích protokolů a podle AD se rozhoduje, který se použije.
  • Na Cisco routrech můžeme měnit defaultní hodnoty.

Nastavení administrativní vzdálenost AD (nižší lepší) provede následující příkaz. Weight je hodnota AD.

ROUTER(config-router)#distance weight [source-ip-address source-mask (access-list-number | name)]
Route Source Default Distance Values
Connected interface 0
Static route 1
EIGRP summary route 5
External BGP 20
EIGRP 90
IGRP 100
OSPF 110
IS-IS 115
RIP 120
EGP 140
On Demand Routing (ODR) 160
External EIGRP 170
Internal BGP 200
Unknown 255

Konvergence

  • procesy a čas potřebný pro konverzi směrovacího protokolu
  • konvergence je dosažena ve chvíli, kdy všechny routry mají kompletní aktuální informaci o topologii

Síťové informace

  • serial interface má default bandwidth rovnu T1 = 1.544Mbps
  • point to multipoint Frame Relay má default rychlost = propustnost_kanálu (T1) / počet_subinterfaců
  • Protocol Data Unit - PDU - záleží na protokolu / vrstvě OSI modelu, takže třeba L2 PDU je rámec, L3 PDU je paket

Obecná konfigurace

Statické routování

SWITCH(config)#ip route [destination_network] [mask] [next_hop or exit_interface] [administrative_distance] [permanent]
SWITCH(config)#ip route 192.168.50.0 255.255.255.0 192.168.1.1 

Defaultní routování - Default gateway

SWITCH(config)#ip default-gateway 10.0.1.250       // definice GW, mohu použít, pouze pokud není zapnuto routování
SWITCH(config)#ip default-network 10.0.1.0         // nastaví defaultní síť, propaguje ji pomocí routovacího protokolu
SWITCH(config)#ip route 0.0.0.0 0.0.0.0 10.0.1.250 // vytvořím záznam do routovací tabulky pro GW

Dynamické routování

SWITCH(config)#ip routing                      // na L3 switchi zapne routing 
SWITCH(config)#router [protokol] [keyword]     // obecně volba routovacího protokolu
SWITCH(config-router)#network [network-number] // definice sítě, která se propaguje, u classles se používá wildcard mask 

Nastavení loopback interface

Loopback se využívá pro řadu účelů, jeho hlavní výhoda je, že je stále up (nikdy nejde down). Takže tam, kde se například router ID počítá z IP adresy routeru se nastaví loopback (jinak, když by šel interface down, tak by se vše přepočítávalo).

SWITCH(config)#interface loopback 0
SWITCH(config-if)#ip address 215.10.7.1 255.255.255.255 

Informace - show příkazy

ROUTER#show ip protocols  // které sítě jsou routovány kterým protokolem a parametry (časovače, filtry, metrika, sítě.)
ROUTER#show ip route      // zobrazí routovací tabulku
ROUTER#show ip interface  // zobrazí informace o interfacech z pohledu IP

Policy Based Routing - PBR - route-map

Obdoba ACL nebo lépe class-map, prochází se číslovaný seznam pravidel. Pravidla obsahují část dvě části:

  • match - na co se uplatní, můžeme použít ip address podle ACL nebo prefix-list, length min, max délka paketu, tag, route type, pokud nezadáme část match, tak se aplikuje na všechny pakety
  • set - co se provede, můžeme použít nastavení precedence, tos, ip next-hop - další router kam poslat, interface - přes který interface routovat, metric - změníme metriku
ROUTER(config)#route-map map-tag [permit | deny ] <Sequence Number>

ROUTER(config)#route-map ospf-to-eigrp deny 10
ROUTER(config-map-router)#match tag 6
ROUTER(config-map-router)#match route type external type-2  // musí platit toto, i předchozí
ROUTER(config)#route-map ospf-to-eigrp permit 20
ROUTER(config-map-router)#match ip address prefix-list pfx  // IP adresu nalezne pomocí prefix-list, jinak možno ACL
ROUTER(config-map-router)#set metric 40000 1000 255 1 1500
ROUTER(config-map-router)#set ip next-hop 142.5.9.1         // na který router se odešle

Následně aplikujeme route-mapu na interface. Můžeme aplikovat pouze jednu route-map per interface, ale route-map se může skládat z více číslovaných částí.

ROUTER(config-if)#ip policy route-map ospf-to-eigrp

Agregace - sumarizace

Často nepotřebujeme znát jednotlivé routy (hlavně v případě propojení více sítí/protokolů), ale stačí znát jak se dostat do hlavní sítě. Takže můžeme skupiny podsítí dostupných přes jeden router nahradit jednou sumarizovanou sítí. Některé protokoly podporují automatickou sumarizaci přes classful hranice sítí (jako EIGRP).

Když se vytvoří sumární routa (v EIGRP nebo BGP), tak se vytvoří Null0 interface (nebo je třeba jej vytvořit), kam směruje tato sumarizovaná routa. Při vlastním routování se použije přesnější adresa (z které se prováděla sumarizace), takže musí existovat záznamy pro jednotlivé podsítě, jinak by data směrovala do Null0. V odesílaných routovacích updatech pak může figurovat pouze sumární routa.

Pokud se u EIGRP smaže poslední specifická routa, která byla použita uvnitř sumarizované, tak se smaže i summary route.

ROUTER(config)#ip route 198.10.0.0 255.255.0.0 null0        // pouze kvůli sumarizaci 
ROUTER(config-router)#redistribute static                   // jenda možnost sumarizace, ručně zadáme routy, spolu s Null0
ROUTER(config-router)#network 198.10.0.0 mask 255.255.255.0 // další možnost agregace, také dohromady s Null0
ROUTER(config-router)#no auto-summary                       // další možnost by byla autosumarizace na classful (EIGRP), ale tu je třeba často vypnout
ROUTER(config-if)#ip summary-address eigrp 100 192.1.0.0 255.255.0.0         // manuální definice sumarizace v EIGRP, 100 = číslo AS
ROUTER(config-router)#aggregate-address 200.52.0.0 255.255.0.0 summary-only  // v BGP, vloží do routovací tabulky sumární routu, pokud se nepoužije summary-only, tak se zveřejňují i ty podsítě, z kterých se sumarizace vytvořila

Route Filtering - filtrace cest v routovacích updatech

Často chceme řídit, jaké routy se mají nacházet v přijímaných (při učení od souseda se odfiltrují určité záznamy) a odesílaných (některé záznamy se ani neposílají sousedovi) updatech k sousedům. Je to z důvodu základní bezpečnosti, skrytí určitých rout od zbytku organizace, kontroly nadbytečného zatížení provozu, zabránění routovacím smyčkám.  Pro řízení máme tři základní metody:

  • passive interface
  • distribute list
  • prefix list

Passive-interface

Nejjednodušší metoda filtrace, která ale nejde příliš do detailů. Pasivní interface neodesílá routovací updaty na daném interfacu, takže se jeho sousedé nedozví o routách. Pro RIP, RIP2 a IGRP se neodesílají updaty sousedům na daném interfacu, ale stále se přijímají a používají updaty od sousedů. Pro EIGRP a OSPF se přestanou odesílat Hello pakety, takže se zruší sousedství, tím pádem nejen že neodesílá updaty, ale také je nepřijímá.

ROUTER(config-router)#passive-interface Serial0/0 // daný interface neposílá updaty
ROUTER(config-router)#passive-interface default   // každý interface, kde není určeno jinak (no passive-interface s0/0), je passive

Distribute-list

Využívá standard IP ACL (případně i extended), pomocí kterého definujeme, které routy nechceme posílat (deny) a které chceme (permit).  Například, když chceme z updatů vyřadit síť 192.168.1.0/24, kterou máme v routovací tabulce, můžeme použít ACL.

ROUTER(config)#access-list 10 deny 192.168.1.0 0.0.0.255
ROUTER(config)#access-list 10 permit any

Distribute list aplikujeme v rámci routovacího procesu a určujeme, zda se použije na odchozí (out) nebo příchozí (in) updaty.

ROUTER(config-router)#distribute-list 10 out   // filtrace odchozích updatů, 10 je číslo ACL

Na jaké updaty se bude omezení aplikovat, můžeme ještě více specifikovat. U příchozích i odchozích můžeme specifikovat interface, kterého se aplikace týká. U odchozích updatů můžeme navíc zadat routing process nebo číslo AS. To se týká redistribuce a pak se aplikuje pouze na updaty ze zadaného routovacího procesu nebo AS

ROUTER(config-router)#distribute-list 10 in ethernet 0 // updaty, které přichází přes interface e0
ROUTER(config-router)#distribute-list 10 out igrp 5    // odchozí updaty, které jsou redistribuovány z IGRP 5
ROUTER(config-router)#distribute-list 10 out 100       // odchozí updaty, které jsou redistribuovány z AS 100

U BGP můžeme použít distribute list na souseda.

ROUTER(config-router)#neighbor 10.0.10.1 distribute-list 10 out

Pozn.: Pro routovací proces můžeme specifikovat celou řadu distribute list, ale na jeden interface a směr může být pouze jeden.

Prefix-list

Prefix list sám o sobě není filtrační metodou. Jedná se pouze o prostředek pro filtraci. Vlastní prefix-list je něco jako ACL, ale pracuje trochu jiným způsobem. Slouží k blokování určitých sítí v updatech od/k sousedům. Je možno jej použít pro BGP s nastavením souseda nebo místo ACL v distribute listu. Podobně jako ACL, je prefix list pojmenovaný číslovaný seznam pravidel, která jsou buď permit nebo deny. Defaultně začíná číslem 5 a po 5 se zvyšuje. Oproti ACL filtruje pomocí prefixů, a to buď přesné délky prefixu nebo rozsahu. Do pravidel se zadává IP adresa a bitově maska (CIDR).

Pozn.: Prefix list můžeme využít nejen při filtraci, ale také pro Policy Based Routing na výběr adresy.

ROUTER(config)#ip prefix-list test deny 0.0.0.0/0        // zakáže defaultní routu 0.0.0.0 
ROUTER(config)#ip prefix-list abc permit 192.0.0.0/8 ge 8 le 24 // bere všechny prefixy >= 8 a <= 24
ROUTER(config-router)#neighbor 170.10.20.1 prefix-list test in  // aplikace filtrování na soused 
ROUTER(config-router)#distribute-list prefix abc in             // jiná možnost aplikace je pomocí distribute listu
ROUTER#show ip prefix-list                                      // zobrazí prefix listy 

Propojení routovacích protokolů - Route Redistribution

Aby se dalo efektivně podporovat více routovacích protokolů v jedné internetwork, musí se sdílet informace mezi protokoly. Tomu se říká route redistribution. Redistribuce může být jednosměrná nebo obousměrná. Routery, které provádí redistribuci, se nazývají boundary (hraniční).

Redistribuce je, když routovací protokol zveřejňuje routy, které se naučil jiným způsobem, to jsou statické routy, přímo připojené interfacy nebo jiný routovací protokol. Různé routovací protokoly mají různé charakteristiky (jako metriku, podporu classles).

Doporučené řešení pro redistribuci mezi dvěma protokoly, kde existuje více cest (kdy si navzájem vyměňují routy), je kvůli smyčkám použit:

  • jednosměrnou redistribuci (na druhou stranu default route)
  • route-mapy či distribution-list, aby se zabránilo přenosu informací, které pochází z daného procesu zpět do něj
  • statické routy
  • ručně nastavit Administrative Distance

Když konfiguruji redistribuci, tak konfiguruji ten protokol, který chci, aby zveřejňoval routy z jiného zdroje. Používá se příkaz redistribute. Při redistribuci musíme nastavit metriku (nastavení záleží na protokolu) nebo se použije defaultní. OSPF má defaultní metriku pro ostatní protokoly 20 mimo BGP, pro které je 1. RIP, IGRP, EIGRP, IS-IS mají defaultní metriku 0 (nekonečno, unreachable, not advertise).

Při redistribuci z classful protokolu (IGRP, RIP) do classless (OSPF) se nedistribují subneted routes. Při redistribuci do OSPF je potřeba použít klíčové slovo subnets, aby se přenesly subnetované routy. Defaultně se routy redistribují do OSPF jako External Type2 (E2).

IGP protokoly (jako RIP, OSPF) redistribujeme do BGP, aby se dostaly do dalších EBGP. Ale musíme být opatrní, protože hrozí nebezpečí smyček, protože redistribuované routy nemusí pocházet z daného AS, ale mohli sem dorazit pomocí BGP.  Pro redistribuci IGP route do BGP se doporučuje použít příkaz aggregate-address.

ROUTER(config)#router rip
ROUTER(config-router)#redistribute static metric 1  // redistribuce statických route
ROUTER(config-router)#redistribute ospf 1 metric 1  // redistribuce OSPF do RIP s nastavením metriky
ROUTER(config-router)#default-metric  1   // nastavení defaultní metriky, které se použije, tam kde ji nezadám
ROUTER(config)#router ospf 1
ROUTER(config-router)#redistribute static metric 200 subnets
ROUTER(config-router)#redistribute eigrp 1 metric 20 metric-type 1 subnet
ROUTER(config)#router eigrp 1                        
ROUTER(config-router)#redistribute rip metric 10000 100 255 1 1500
ROUTER(config-router)#redistribute ospf 1 match external 1 external 2  // redistribuujeme pouze typ E1 a E2
ROUTER(config-router)#redistribute isis level-1-2 metric 100 100 200 1 1500 // redistribuujeme ISIS L1 i L2
ROUTER(config-router)#redistribute ospf 1 route-map ospf-to-eigrp      // použití route-mapy pro filtrování, co se přenáší

Pro troubleshooting se mohou použít dva příkazy.

ROUTER#show ip route    // na routeru uvnitř i na ASBR, zda zde jsou redistribuované routy
ROUTER#show ip protocol // na ASBR, ověří konfiguraci redistribuovaných route, zobrazuje i filtry
zobrazeno: 50225krát | Komentáře [12]

Autor:

Související články:

Routing - směrování

Směrování paketů mezi jednotlivými počítačovými sítěmi (LAN) se provádí technikou zvanou routing. Používají se k tomu různé routovací protokoly. Routing je jedna ze základních částí komunikace v internetu.

Cisco IOS

Velký seriál o operačním systému aktivních prvků firmy Cisco.

Pokud se Vám článek líbil, tak mne potěšíte, když uložíte odkaz na některý server:

Pokud se chcete vyjádřit k tomuto článku, využijte komentáře níže. Pokud chcete poradit s nějakým problémem či diskutovat na nějaké téma, tak použijte fórum.

Komentáře

  1. [1] tomfi

    Zdravím,

    tak je tam pár chybyček:

    "Eigrp - Hybrid Routing Protokol" - myslím že umno ale budíž (jedž i Cisco od tohoto termínu upustilo ... en z hybridních protokolů je OSPF, EIGRP je čistý DV, žádný hybrid).

    "Distance-Vector Routing Protocol:

    nevytváří vztahy se sousedy"

    Ale vytváří... i BGP, i EIGRP vytváří vztah partnerství mezi směrovači.

    "Route Poisoning" jste mám dojem úplně nepochopil...

    Dál už raději nečtu, je možné že je tam toho víc ;)

    (na začátek doporučuju nějakou základní knihu o směrování, například Routing TCP/IP nebo podobnou s "routing" v názvu ;) )

    Pondělí, 23.03.2009 13:53 | odpovědět
  2. [2] tomfi

    omlouvám se... nějak se mi zkomolila poznámka u eigrp, oprava:

    "Eigrp - Hybrid Routing Protokol" - myslím že už i Cisco od tohoto termínu upustilo ... mno ale budíž (jeden z hybridních protokolů je OSPF, EIGRP je čistý DV, žádný hybrid)

    Pondělí, 23.03.2009 13:54 | odpovědět
  3. [3] Samuraj

    odpověď na [1]tomfi: Na úvod, knih jsem přečetl několik. Například oficiální Cisco příručku k testu. Trochu problém je, když ve třech knihách/zdrojích se nachází rozdílná informace, komu má potom člověk věřit? Vy vypadáte naprosto přesvědčen o svých vědomostech, tak by mne zajímalo, odkud je čerpáte?

    Že je EIGRP hybridní protokol se píše (mimo jiné) přímo v oficiální knize od Cisco Press. A vy chcete říct, že třeba spolehlivost linky je vektor vzdálenosti? Podle mne je to spíše stav linky.

    Ano, opravil jsem, vztahy se sousedy nevytváří pouze čisté DVRP.

    Pondělí, 23.03.2009 14:14 | odpovědět
  4. [4] Samuraj

    Ještě, aby to nevyznělo nějak jinak, než to myslím. Jsem rád, pokud někdo opraví chyby, které se zde určitě mohou vyskytovat.

    Pondělí, 23.03.2009 14:37 | odpovědět
  5. [5] tomfi

    Omlouvám se, nějak jsem si nevšiml, že ten můj příspěvek zazní tak "přesvědčeně", ale vy víte, že jsem rád že vaše články vznikají, a že myslím, že jsou kvalitní... jenom si občas rád trochu pošťouchnu :)

    Z čeho čerpám? Tak namátkou z paměti:

    Routing TCP/IP

    Interconnections: Bridges...

    Network Routing: Algorithms... (pokud jste zatím nic z toho nečetl, tak doporučuju touhle knihou začít:) )

    Materiály CCNA (trochu štouchnutí (myslím, že umíte víc), ale i tam to je tak jak píši)

    plus mnoho dalších knih, a článků z odborních periodik (tím nemyslím computer :D, ale články kde jsou vypublikovány původní algoritmy, myšlenky a popisy protokolů "tak jak je autoři zamýšleli" ;).

    Co se týče cert. Guidů (některé jsem také četl, například i ty na CCNP), tak tam je tolik "zjednodušení", že je třeba to brát oooopravdu s rezervou... ono víceméně certifikace je také o tom odpovídat "Cisco pravdu" :)

    Co se týče EIGRP a hybridnosti... nevím proč s tím cisco začalo (osobně myslím, že to byl marketingový tah). Ale EIGRP je čistě DV protokol.

    Linkstate znamená informace o stavu linky, tedy zařízení mají informace o topologii sítě (informaci o linkách (propojeních) v síti. Na základě těchto informací vypočítají nejkratší cestu, většinou implementací nějaké podoby dijkstrova algoritmu.

    DV znamená, že pro výpočet cesty se nevyužívá znalost topologie, ale pouze vektorů (cest, směrů...). Jestli je pro výpočet "distance" využívána jedna konkrétní metrika nebo několik vlastností, které se před výpočtem cesty převádí na jednu metriku (viz. EIGRP vzoreček), na tom nesejde. Pro hledání cesty se většinou využívá nějaká podoba bellman-fordova algoritmu.

    To je velké zjednodušení, více se do 2000 znaků příspěvku nevejde :D

    Pondělí, 23.03.2009 15:46 | odpovědět
  6. [6] Samuraj

    odpověď na [5]tomfi: Díky za informace. Budu si to muset nechat projít hlavou. Routing v praxi nikde nekonfiguruji a učil jsem se pouze na test na CCNP (který jsem úspěšně složil se znalostmi, které zde, a dále, uvádím ;-)). A to mi to studium zabralo několik měsíců.

    Pondělí, 23.03.2009 16:24 | odpovědět
  7. [7] tomfi

    "Budu si to muset nechat projít hlavou."

    Tak tak... není dobré důvěřovat, je třeba prověřovat... nedůvěra vede k poznání, pochopení... důvěra pouze k naučení, namemorování :)

    Jinak taky jsem nejdřív nevěděl co číst... tahle stránka mi pomohla s výběrem:

    http://www.internetworkexpert.com/resources/cciebooks.htm

    Pondělí, 23.03.2009 18:19 | odpovědět
  8. [8] Vojtech

    odpověď na [5]tomfi:

    "Materiály CCNA (trochu štouchnutí (myslím, že umíte víc), ale i tam to je tak jak píši)"

    v materialech ICND2, ktere byly platne minimalne jeste v '08 se o EIGRP jako o hybridu pise

    Sobota, 28.03.2009 11:09 | odpovědět
  9. [9] tomfi

    odpověď na [8]Vojtech:

    Aspoň vidíte, že v materiálech je chyb tolik, že vysekat je všechny bude nějáký ten rok trvat :D... Ale nechme na zamyšlenou, jestli na těch nižších certifikačních úrovních pořád neprosazují myšlenku, že EIGRP je hybridní schválně. Přeci jenom moci uvádět, že EIGRP je konkurent OSPF je lepší, než když by EIGRP srovnávali s RIPem :D

    Ty materiály, které jsem uváděl jako CCNA jsem měl na mysli CCNA Exploration, CNA programu.

    Neděle, 29.03.2009 12:47 | odpovědět
  10. [10] tomfi

    odpověď na [9]tomfi:

    Ještě bych se možná poupravil... ono to na spiknutí nevypadá... jenom prostě zažitá "pravda", jako že špenát má hodně železa :)....

    Při tvorby materiálů záleží spíše na znalostech autora spíše než na politice firmy.

    Cisco na vlastních stránkách píše:

    http://www.cisco.com/en/US/docs/internetworking/technology/handbook/Enhanced_IGRP.html

    "EIGRP integrates the capabilities of link-state protocols into distance vector protocols"

    Co za těmi capabilities přímo myslí je otázka... ale jednoznačně to neimplikuje, že EIGRP je nějakým způsobem hybridní. Prostě jenom "trochu" vylepšený DV.

    Když integruji vylepšení z raketoplánu do auta (jako třeba kevlarové díly), určitě nemáte hybridní auto ani nic mezi autem a raketoplánem, prostě pořád máte auto :D

    Neděle, 29.03.2009 13:02 | odpovědět
  11. [11] Samuraj

    odpověď na [10]tomfi: Hledal jsem trochu po netu a v hodně článcích se uvádí to značení Hybrid Routing Protocol (třeba www.ciscopress.com/articles/article.asp?p=99982&seqNum=3). Skoro všude se k tomu uvádí to, že EIGRP je v základu Distance Vector, který obsahuje i některé vlastnosti Link State.

    Na druhou stranu, například na Wikipedii (en.wikipedia.org/wiki/EIGRP) někdo vysvětluje to, co jste říkal vy, že to označení Hybrid není správné. A například v odkazu, který jste uváděl, jej Cisco nepoužívá. Dává to smysl, takže jsem upravil info v článku.

    Neděle, 29.03.2009 18:58 | odpovědět
  12. [12] Petra

    Ahoj, vidím, že jste tady všichni velcí odborníci, tak bych vás ráda poprosila o radu...je nějaká obdoba certifikátu cisco? myslím tím jiný certifikát na stejné úrovni, který by mohl být např. u pohovorů do zaměstnání přijímán místo cisca? děkuji moc za odpověď

    Čtvrtek, 28.02.2013 08:46 | odpovědět
Přidat komentář

Vložit tag: strong em link

Vložit smajlík: :-) ;-) :-( :-O


Ochrana proti SPAMu, zdejte následující čtyři znaky image code

Nápověda:
  • maximální délka komentáře je 2000 znaků
  • HTML tagy nejsou povoleny (budou odstraněny), použít se mohou pouze speciální tagy (jsou uvedeny nad vstupním polem)
  • nový řádek (ENTER) ukončí odstavec a začne nový
  • pokud odpovídáte na jiný komentář, vložte na začátek odstavce (řádku) číslo komentáře v hranatých závorkách