www.SAMURAJ-cz.com 

18.12.2017 Miloslav Translate to English by Google     VÍTEJTE V MÉM SVĚTĚ

Články

Cisco MDS - konfigurace Fibre Channel SAN sítě

Upraveno 11.12.2016 09:45 | vytvořeno 29.08.2016 20:46 | Samuraj - Petr Bouška |
Článek stručně popisuje základní konfiguraci SAN sítě s použitím Cisco switchů MDS řady 9000. Ty používají operační systém Cisco NX-OS. Nejprve je malý úvod, následně konfigurace portů, VSAN a zónování. V závěru jsou příkazy pro zobrazení užitečných informací. Výhodou je znalost Cisco NX-OS či IOS a technologie Fibre Channel (FC).

Cisco MDS jsou Fibre Channel SAN (Storage Area Network) přepínače (řada MDS 9000). Tyto switche používají jako operační systém NX-OS, stejně jako ethernetové přepínače řady Nexus. Konfigurace je tedy obdobná jako u Nexusů, i když zde se používají optické FC porty místo metalických/optických ethernetových a pro speciální účely jsou tedy nové příkazy. Konfigurace Nexusů je zase docela obdobná konfiguraci Catalyst přepínačů, které používají Cisco IOS.

Základní termíny

FC - Fibre Channel  - je fullduplexní, sériové, blokově orientované, bod-bod komunikační rozhraní (síťová technologie), navržené pro vysokorychlostní přenos dat (pracuje v gigabitových rychlostech). Běžně se využívá pro připojení diskových polí (computer data storage) k serverům v SAN sítích. Mohou se využít různá fyzická média pro přenos, standardně jde o optická vlákna (optical fibre) nebo metalické kabely (TP). Využívá se přenosový protokol Fibre Channel Protocol (FCP) nebo  Fibre Channel over Ethernet (FCoE), což je zapouzdření FC rámců do Ethernetových sítí.

Fabric - Fibre Channel Fabric nebo Switched Fabric, jde o síťovou topologii používanou v FC sítích (ze tří možných je nejpoužívanější). Fabric je jedna uzavřená síť (SAN). Skládá se z jednoho nebo více přepínačů (FC switch), do kterých jsou připojena koncová zařízení (servery a úložiště). Je to velice podobné klasické LAN síti, více zařízení může být aktivních najednou, médium není sdílené. Kvůli vysoké dostupnosti se SAN síť standardně buduje tak, že máme dvě samostatné fabricy (dvě navzájem nepropojené skupiny přepínačů, koncová zařízení jsou připojena do obou), tedy dvě nezávislé cesty.

Základní konfigurace

Konfiguraci můžeme provádět pomocí CLI (příkazové řádky), což se mi zdá nejlepší, stejně jako u konfigurace Cisco IOS. Nebo pomocí aplikace Device Manager, která poskytuje grafickou reprezentaci MDS přepínače a umožňuje určitou konfiguraci pomocí GUI (stáhnout ji můžeme z webového rozhraní přepínače).

Pokud máme přepínač v továrním nastavení, tak se po připojení na konzoli spustí jednoduchý konfigurační průvodce, který nám umožní nastavit autentizaci, SNMP, IP adresu na Out-of-band management rozhraní (mgmt0) a několik dalších základních hodnot.

Na switchi máme dva RJ-45 konektory, klasicky jeden Console port, kde se připojíme modrým Cisco sériovým kabelem, a Ethernet management port, který připojíme do sítě a přes něj provádíme správu.

Běžné nastavení přepínače provedeme stejně, jako když konfigurujeme Nexus nebo Catalyst. Pokud jste si, stejně jako já, zvykli na alias write pro uložení konfigurace, který není ani na Nexusech, tak si jej můžeme jednoduše doplnit (já používám zkratku wri).

SWITCH(config)#cli alias name wri copy running startup

Konfigurace interface (portů)

Na switchi máme rozhraní Fibre Channel, management (mgmt0) a VSAN. Porty přepínače jsou Fibre Channel (FC) a pro jejich označení používáme zkratku fc (obdobně jako pro GigabitEthernet třeba Gi). Identifikace portu je opět podobná jako u Ethernetového přepínače, například fc1/1, kde se používá číslo slot/port. Můžeme konfigurovat najednou více portů a na rozdíl od IOSu k tomu nepotřebujeme klíčové slovo range.

SWITCH(config)#interface fc1/1 - 5, fc1/10
SWITCH(config-if)#switchport description POPIS
SWITCH(config-if)#port-license acquire 
SWITCH(config-if)#no shutdown 

Ve světě Fibre Channel nepoužíváme MAC adresy, ale obdobně WWN - World Wide Name. Pokud je Fibre Channel interface nakonfigurovaný, tak má automaticky přiděleno unikátní WWN. Pokud je jeho stav up, tak má také Fibre Channel ID (FC ID).

  • WWN - World Wide Name - unikátní identifikátor používaný ve světě Fibre Channel, obdoba MAC adresy v Ethernetu
  • WWPN - World Wide Port Name - WWN přiřazené portu ve Fibre Channel Fabric, Cisco někde používá označení Port WWN
  • WWNN - World Wide Node Name - WWN přiřazené nodu (koncové zařízení, diskové pole, switch) ve Fibre Channel Fabric, na všech portech zařízení může být vidět stejné WWNN, ale pokaždé jiné WWPN
  • FCID - Fibre Channel ID - přesněji Fibre Channel Node Port Identifier, také se používá zkratka N Port ID, 24-bitové číslo, které se přiděluje koncovému zařízení (N Port) při FLOGI procesu. Switch používá FCID pro směrování (route) rámců z daného zdroje (initiator) na určitý cíl (target) v rámci SAN fabricy.

Módy portů

Každý port přepínače může pracovat v určitém módu: E, F, FL, TL, TE, SD, ST, B. Při nastavování můžeme využít ještě dvě speciální hodnoty Fx (znamená F nebo FL mód, tedy připojení zařízení) a auto (automaticky se vyjednává mód E, F, FL nebo TE). Z mého pohledu jsou hlavní módy:

  • F port - Fabric port mode - zjednodušeně sem připojujeme server nebo diskové pole. Port ve Fabric módu slouží k připojení zařízení (host nebo disk), které funguje jako N port. Do F portu můžeme připojit pouze jeden N port.
  • E port - Expansion port mode - zjednodušeně sem připojíme jiný SAN přepínač. Port v Expansion módu slouží k připojení k jinému E portu pro vytvoření Inter-Switch Link (ISL) mezi dvěma přepínači. Můžeme jej nastavit jako PortChannel.
  • TE port - Trunking Expansion port mode - E port, který pracuje v Trunk módu, takže může přenášet více VSAN, další popis v kapitole VSAN Trunk
  • N port - Node port - jde o port na straně koncového zařízení (může jít o HBA port serveru nebo target port na diskovém poli)
SWITCH(config)#interface fc1/1
SWITCH(config-if)#switchport mode F
Cisco Fibre Channel módy portů

Port Channel

Opět identicky jako u ethernetových switchů můžeme agregovat více portů do jednoho virtuálního a zvýšit dostupnost a rychlost. Vytváříme Port Channel, do kterého můžeme zařadit E porty nebo TE porty (popis TE portů je dále, na MDS 9000 můžeme spojovat až 16 portů a vytvořit až 128 Port Channelů). V následujícím příkladu jsou porty fc1/47 a fc1/48 spojeny do Port Channelu 1. Port zařazený do Port Channelu se automaticky vypne (shutdown).

SWITCH(config)#interface fc1/47 - 48
SWITCH(config-if)#switchport mode E
SWITCH(config-if)#channel-group 1 force
SWITCH(config-if)#no shutdown

Následně můžeme konfigurovat vlastnosti Port Channelu, třeba zapnout PortChannel protokol (defaultní možnost je on, kde se protokol nepoužívá) a nastavit povolené VSAN do trunku.

SWITCH(config)#interface port-channel1
SWITCH(config-if)#channel mode active
SWITCH(config-if)#switchport trunk allowed vsan 10

Konfigurace VSAN

Virtual Storage Area Network (VSAN) je obdoba VLAN (Virtual Local Area Network) z Ethernetu (vytvořená Ciscem a v současnosti ANSI standard). Pomocí VSAN spojíme porty a vytvoříme virtuální fabric. Jeden port může patřit do více VSAN a porty z různých switchů mohou být zařazeny do stejné VSAN. V rámci VSAN máme oddělený provoz, stejně jako security policy, zóny, členství, apod. Defaultně existuje VSAN 1, která se nedoporučuje užívat pro provozní účely. Využít můžeme VSAN 1 až 4093.

Pro vytvoření VSAN a jejich konfiguraci se nejprve musíme přepnout do speciálního konfiguračního módu.

SWITCH(config)#vsan database
SWITCH(config-vsan-db)#vsan 10
SWITCH(config-vsan-db)#vsan 10 name Jmeno

Zařazení portu do VSAN se neprovádí na portu, ale v konfiguraci VSAN.

SWITCH(config)#vsan database
SWITCH(config-vsan-db)#vsan 10 interface fc1/2

VSAN Trunk

Další obdobná vlastnost jako u VLAN a Ethernetu je Trunking (VSAN trunking). Port v Trunk módu může přenášet rámce ve více než jedné VSAN. Musí se jednat o E port, kde je vytvořeno ISL, a používá se Extended ISL (EISL) formát rámce. Když se využívá trunking, tak port nastavený jako E port pracuje v režimu Trunking E port, tedy TE port. Konfigurujeme jej jako E port (ve výpisu vidíme pod Admin Mode) a automaticky pracuje jako TE port (ve výpisu Operational mode).

Pro vyjednání práce v Trunk módu se používá Trunking Protocol, který je defaultně povolený. Pokud jej zakážeme, tak se žádný port nepřepne do TE módu (aktivní zůstanou).

SWITCH(config)#no trunk protocol enable
SWITCH(config)#trunk protocol enable

Defaultně je Trunk mód povolen na všech Fibre Channel portech, ale ovlivňuje pouze E porty. Nastavit můžeme on, off, auto.

SWITCH(config-if)#switchport trunk mode off

Defaultně jsou v Trunk módu povoleny všechny VSAN, ale jejich seznam můžeme omezit.

SWITCH(config)#interface fc1/48
SWITCH(config-if)#switchport mode E
SWITCH(config-if)#switchport trunk allowed vsan 10, 20

Konfigurace zón - zónování

SAN switch můžeme nastavit tak, že všechna zařízení (ve stejné VSAN) mohou vzájemně komunikovat. To se ale nedělá a provádí se zónování (Zoning), čímž nastavíme řízení přístupu mezi zařízeními a zvýšíme tak bezpečnost sítě i dat. Vytváříme zóny (Zones) v rámci určité VSAN a pouze zařízení v dané zóně spolu mohou komunikovat. Zařízení, které není zařazené do žádné zóny, používá politiku defaultní zóny.

FC aliasy

Při zařazování do zón můžeme pracovat s interface, FC ID, port WWN a dalšími typy. Často využíváme port WWN (WWPN), což je adresa podobná MAC adrese. Abychom měli práci a konfiguraci přehlednější, tak můžeme vytvářet FC alias pro tyto WWN.

SWITCH(config)#fcalias name Server-port-A vsan 10
SWITCH(config-fcalias)#member pwwn 50:05:0c:00:00:c8:aa:50

Zóny

Vytvoření / editace zóny ve VSAN 10 a zařazení dvou členů pomocí aliasu.

SWITCH(config)#zone name Server vsan 10
SWITCH(config-zone)#member fcalias Server-port-A
SWITCH(config-zone)#member fcalias Pole-port-1

Zone set a jejich aktivace

Zóny následně seskupujeme do zón setů (Zone Set), kde může být jedna nebo více zón. Celý zoneset pak společně aktivujeme nebo deaktivujeme (po přidání zóny je vždy potřeba aktivovat) jako jednu entitu přes všechny přepínače ve fabrice. Zónování můžeme spravovat z libovolného switche ve fabrice. Když aktivujeme zoneset, tak všechny switche ve fabrice obdrží aktivní zoneset.

SWITCH(config)#zoneset name SAN-VSAN10 vsan 10
SWITCH(config-zoneset)#member Server
SWITCH(config)#zoneset activate name SAN-VSAN10 vsan 10

Zobrazení informací

Pouze stručný výpis některých show příkazů pro vlastnosti konfigurované výše:

SWITCH#show interface brief

SWITCH#show vsan
SWITCH#show vsan usage
SWITCH#show vsan membership
SWITCH#show zone
SWITCH#show zoneset vsan 10
SWITCH#show fcalias vsan 1
SWITCH#show zone statistics
SWITCH#show zoneset active
SWITCH#show zone active
SWITCH#show zone status

O trochu více se podíváme na dva příkazy, které nám zobrazují informace o aktivních port WWN a FC ID.

FLOGI - Fabric Login

Na switchi se vytváří databáze Fabric Login (FLOGI). Když se zařízení připojí do portu a linka se přepne do aktivního stavu (up), tak dochází k jeho přihlášení (login) do fabric topologie. V té chvíli dostává přiděleno dynamické 3-bytové Fibre Channel ID (FC ID), k tomu má svoje pevně dané 8-bytové Port WWN.

FLOGI tabulku (databázi) si můžeme vypsat a ta nám ukáže seznam portů a aktivní (přihlášená) zařízení a jejich FC ID, Port WWN a WWN. Takže pokud správně nakonfigurujeme port a připojíme zařízení, tak se takto dozvíme jeho WWPN a můžeme nastavit zónování.

SWITCH#show flogi database
--------------------------------------------------------------------------------
INTERFACE        VSAN    FCID           PORT NAME               NODE NAME
--------------------------------------------------------------------------------
fc1/1            10    0x5e0000   50:40:20:c0:00:f6:93:da 50:40:20:c0:00:f6:93:db

FCNS - Fibre Channel Name Server

Další databáze se vytváří pro celou VSAN a obsahuje atributy pro všechny hosty a zařízení pro ukládání dat, označuje se jako Name Server Database a používá zkratku FCNS. Záznam se vytváří při přihlášení zařízení Port Login (PLOGI) a ruší při odhlášení. Instance FCNS databáze běží na každém switchi a sdílí mezi sebou informace. Databázi si můžeme vypsat a získat tak užitečné informace.

SWITCH#show fcns database
VSAN 10:
--------------------------------------------------------------------------
FCID        TYPE  PWWN                    (VENDOR)        FC4-TYPE:FEATURE
--------------------------------------------------------------------------
0x5e0000    N     50:40:20:c0:00:f6:93:da                 scsi-fcp:init

SWITCH#show fcns database vsan 10
SWITCH#show fcns database detail
zobrazeno: 4141krát | Komentáře [2]

Autor:

Související články:

Cisco NX-OS

Články, věnující se novějšímu operačnímu systému aktivních prvků firmy Cisco, NX-OS. Ten se používá na ethernetových přepínačích řady Nexus a Fibre Channel přepínačích MDS.

Computer Storage

Ukládání dat je v počítačovém světě rozsáhlá a komplexní problematika. Zde se nachází články, které se věnují sítím Storage Area Network (SAN), technologiím iSCSI, Fibre Channel, diskovým polím (Storage System, Disk Srray) i obecně ukládání dat a úložištím.

Pokud se Vám článek líbil, tak mne potěšíte, když uložíte odkaz na některý server:

Pokud se chcete vyjádřit k tomuto článku, využijte komentáře níže. Pokud chcete poradit s nějakým problémem či diskutovat na nějaké téma, tak použijte fórum.

Komentáře

  1. [1] 1

    Lze FC (Fibre Channel) použít jako LAN síťovou kartu?

    Středa, 01.03.2017 22:56 | odpovědět
  2. [2] Samuraj

    odpověď na [1]1: Mám tu nový článek věnovaný FC, kde je to snad více vysvětleno. Fiber Channel síť je úplně jiná technologie nežli Ethernet, takže FC HBA nelze použít pro připojení do LAN.

    Středa, 01.03.2017 23:43 | odpovědět
Přidat komentář

Vložit tag: strong em link

Vložit smajlík: :-) ;-) :-( :-O


Ochrana proti SPAMu, zdejte následující čtyři znaky image code

Nápověda:
  • maximální délka komentáře je 2000 znaků
  • HTML tagy nejsou povoleny (budou odstraněny), použít se mohou pouze speciální tagy (jsou uvedeny nad vstupním polem)
  • nový řádek (ENTER) ukončí odstavec a začne nový
  • pokud odpovídáte na jiný komentář, vložte na začátek odstavce (řádku) číslo komentáře v hranatých závorkách